Accueil Actualité Archive forum Matériel Annonces Consentement

Kodi pour linux


#1

Je n’ arrive pas à lire les vidéos de youtube sur KODI.
Est-ce qu’ un pongiste pourrait m’ aider?
Merci d’ avance.


(10 - Rossi Emotion / Vega Intro / Vega Intro) #2

Salut !
Tu utilises quel plugin et quelle version de kodi ?
Tu ouvres la vidéo depuis ton kodi ou bien tu l’envoi sur ton media center depuis un smartphone/tablette ?


#3

Bonjour.
J’ ai installé la version Krypton de KODI en suivant cette procédure: https://doc.ubuntu-fr.org/kodi.
KODI est installé sur mon PC portable LENOVO G70.
L’ extension installé est Vstream.
Quand je lance une vidéo sur youtube, KODI se ferme.

J’ ai installé KODI sur une Freebox mini 4 k, tout fonctionne.
Merci pour ton aide.


(10 - Rossi Emotion / Vega Intro / Vega Intro) #4

Je suis pas chez moi, mais de mémoire j’utilisais ce plugin la https://kodi.tv/addon/plugins-video-add-ons/youtube


#5

Merci pour l’ info, j’ essaierai ce soir mais j’ ai un doute.
J’ ai essayé de regardé la série “Breaking bad” via une autre l’ extension et j’ ai le même souci.


(10 - Rossi Emotion / Vega Intro / Vega Intro) #6

Tu utilise kodi sur openelec ou sur une distribution complète ? Laquelle ?
Si distribution, tu as le soucis également avec Firefox ?


#7

Bonjour
Merci de me suivre dans mes problèmes.
J’ ai installé Kubuntu 14.04 sur mon Lenovo.
Pas de problème avec Firefox (je lis correctement Youtube et autres…)


(10 - Rossi Emotion / Vega Intro / Vega Intro) #8

Pour essayer de trouver d’ou ça viens, il faut que tu active les options de debug.
Va dans “paramètres/système” et active les options de debug

Relance de nouveau une video, puis regarde le fichier de log $HOME/.kodi/temp/kodi.log
Regarde à la fin du fichier, tu devrait trouver les messages d’erreur relatif à ton problème.

(tu as également ces infos dans http://kodi.wiki/view/Log_file/Advanced#Log_files)


#9

C’ est un peu du charabia pour moi mais les seules lignes où il y a “error” c’ est celles-ci:

"10:56:43.615 T:139834790237952 ERROR: /home/mdu02/.kodi/addons/script.module.requests/lib/requests/packages/urllib3/util/ssl_.py:334: SNIMissingWarning: An HTTPS request has been made, but the SNI (Subject Name Indication) extension to TLS is not available on this platform. This may cause the server to present an incorrect TLS certificate, which can cause validation failures. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/advanced-usage.html#ssl-warnings
SNIMissingWarning
10:56:43.615 T:139834790237952 ERROR: /home/mdu02/.kodi/addons/script.module.requests/lib/requests/packages/urllib3/util/ssl_.py:132: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/advanced-usage.html#ssl-warnings
InsecurePlatformWarning "


(10 - Rossi Emotion / Vega Intro / Vega Intro) #10

Bon, visiblement ta version de python pose problème. En principe, si tu tape ceci dans un terminal, tu devrait avoir une version 2.7.6

python --version

Or le message que tu rencontre est corrigé à partir de la 2.7.9 ( voir https://urllib3.readthedocs.io/en/latest/advanced-usage.html#ssl-warnings )

SNIMissingWarning
This happens on Python 2 versions older than 2.7.9. These older versions lack SNI support. This can cause servers to present a certificate that the client thinks is invalid

Comme indiqué dans le lien affiché dans le message d’erreur, tu peux essayer de corriger l’anomalie en essayant d’ajouter une extension qui prend en charge la verification des certificats SSL

sudo pip install urllib3[secure]

Si ça ne fonctionne pas, je pense que tu n’aura pas d’autre choix que de mettre à jour ta version d’ubuntu qui commence à être franchement vieille.


#11

python–version me donne "Python 2.7.6"
J’ essaie ton sudo et je te tiens au courant.
Merci.


#12

[email protected]:~$ sudo pip install urllib3[secure]
[sudo] password for mdu02:
sudo: pip: command not found


#13

Quelle version de Linux me conseillerais-tu (Ubuntu ou Kubuntu)?


(10 - Rossi Emotion / Vega Intro / Vega Intro) #14

J’ai pas plus de préférence que ça… si tu est habitué à une kubuntu et que cela te convient, reste dessus… passe simplement à une version plus récente :wink:


#15

Apparemment ma Kubuntu 14.04 ne connait pas la commande “sudo pip install…”


(10 - Rossi Emotion / Vega Intro / Vega Intro) #16

Tu doit pouvoir suivre ce tuto pour installer “pip” : https://www.liquidweb.com/kb/how-to-install-pip-on-ubuntu-14-04-lts/

(ajoute “sudo” devant chaque commande)


#17

Après avoir exécuter les deux commandes et les vérifications souhaitées sur le site que tu m’ as indiqué, la commande “sudo pip install urllib3[secure]” me retourne:
[email protected]:~$ sudo pip install urllib3[secure]
[sudo] password for mdu02:
Requirement already satisfied (use --upgrade to upgrade): urllib3[secure] in /usr/lib/python2.7/dist-packages
Installing extra requirements: 'secure’
Cleaning up…”

J’ai relancé mon pc, ouvert Kodi, lancé Youtube et essayé de regarder une vidéo de ping, Kodi recherche la vidéo puis se ferme.


(10 - Rossi Emotion / Vega Intro / Vega Intro) #18

et tu as toujours les mêmes messages d’erreur dans $HOME/.kodi/temp/kodi.log ?

Si oui, je n’ai pas de solution … pose la question peut être sur le forum kodi ?


#19

Bonjour
J’ ai toujours les mêmes erreurs:
“ERROR: /home/mdu02/.kodi/addons/script.module.requests/lib/requests/packages/urllib3/util/ssl_.py:334: SNIMissingWarning: An HTTPS request has been made, but the SNI (Subject Name Indication) extension to TLS is not available on this platform. This may cause the server to present an incorrect TLS certificate, which can cause validation failures. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/advanced-usage.html#ssl-warnings
SNIMissingWarning”

D’ après ce que je peux traduire ma version de Python est mise en cause.


(1629 - V1- VIP 2018 + battle2 + aero soft carbon) #20

C’est pas totem qui lit les vidéos sur ubuntu?
Tu as fais toutes les mises à jours de ta version linux? Normalement sur youtube c’est un plugin flash player, non?